1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

artio-joomsef 3.2.10

Тема в разделе "Joomla", создана пользователем vanderv, 5 июл 2009.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. vanderv

    vanderv

    Регистр.:
    30 май 2009
    Сообщения:
    267
    Симпатии:
    12
    установил у ся на denwer artio joomsef.
    сразу после установки, пишит всё норм, я пытаюсь открыть другую страницу а вместо неё открывается вот это

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Подсказка Денвера
    Вероятнее всего, скрипт, который запускает данная страница, не смог корректно выполниться. Детально причины ошибки должны быть описаны в файле Z:/home/test1.ru/error.log.

    Вот наиболее частые причины 500-й ошибки:

    * В скрипте имеются ошибки. Например, каждый скрипт должен выводить заголовок Content-Type перед началом печати страницы. Подробнее об этом читайте в статье Борьба с 500-й Ошибкой закончилась.

    Корректные пути к CGI-директориям следующие:

    URL Куда указывает
    http://***/cgi-glob/script.cgi /home/cgi-glob/script.cgi
    http://***/cgi/script.cgi /home/***/cgi/script.cgi
    http://***/cgi-bin/script.cgi /home/***/cgi-bin/script.cgi

    * Вы не установили некоторые библиотеки, которые необходимы скрипту. Для Perl-скриптов: установите пакет с библиотеками Perl, который доступен по адресу http://dklab.ru/chicken/web/packages/perl.html.
    * Вы указали неправильную первую строчку в скрипте, по которой Apache определяет путь к интерпретатору. Первая строка должна быть:
    o для Perl:

    #!/usr/bin/perl -w

    или

    #!/usr/local/bin/perl -w

    o для PHP:

    #!/usr/bin/php

    или

    #!/usr/local/bin/php

    Здесь указывается путь относительно корня до файлов perl.exe и php.exe соответственно (расширение exe и буква диска опускаются для совместимости с Unix). Проверьте, чтобы до этой строке в скрипте ничего не было (в том числе и комментариев).

    Хотя Денвер поддерживает оба варианта, заметьте также, что PHP-скрипты удобнее запускать из-под mod_php, встроенного в Apache, а не через внешнюю программу php.exe. Для использования mod_php просто поместите PHP-скрипт в www-директорию (а не в директорию с CGI-скриптами).
    * В текущей директории расположен файл .htaccess с ошибочными директивами. Например, Apache в Денвере не поддерживает устаревший модуль mod_charset, имеющийся у некоторых хостеров, и расценивает директивы вроде CharsetDisable как ошибочные. Для того, чтобы исправить ситуацию, отредактируйте файл .htaccess, чтобы он выглядел примерно так:

    <IfModule mod_charset.c>
    CharsetRecodeMultipartForms off
    # и другие директивы mod_charset
    </IfModule>

    плиз... помогите, ваще никуда зайти не могу!!!!
     
  2. dmon74

    dmon74 Создатель

    Регистр.:
    1 июн 2009
    Сообщения:
    11
    Симпатии:
    5
    Если будешь использовать Virtuemart на сайте не пользуйся Artio JoomSEF. Тебе прийдется покупать плагин для поддержки Virtuemart. Лучше используй бесплатный sh404sef. Да и вообще говорят, что Artio JoomSEF грузит сайт.
     
  3. dimadav

    dimadav Постоялец

    Регистр.:
    15 фев 2008
    Сообщения:
    60
    Симпатии:
    19
    Такая же байда. htaccess убираешь, тогда в админку можно войти, пришлось снести, sh404sef под джмлу 1.5.12 тоже неудалось запустить
     
  4. mptz

    mptz

    Регистр.:
    22 июн 2006
    Сообщения:
    436
    Симпатии:
    180
    Причиной ошибки 500 является не правильно сконфигурированный файл .htaccess. У меня решилось так:

    Код:
    DirectoryIndex index.php
    RewriteEngine on
    
    [COLOR=Red]RewriteBase [/COLOR] [удаляем или добавляем так [COLOR=Red]"RewriteBase /" [/COLOR]]
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^/index.php
    RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
    RewriteRule (.*) index.php
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    
    Незабудь включить в общих настройка joomla ЧПУ ("Включить SEO" и "Использовать od_rewrite");
    (чтобы получить доступ в админку временно переименуй файл .htaccess в любой другой, а после включения опций ЧПУ в общих настройках - переименуй обратно)
     
  5. dimadav

    dimadav Постоялец

    Регистр.:
    15 фев 2008
    Сообщения:
    60
    Симпатии:
    19
    оказалось, у меня стоит joomfish, и в артио надо было в настройках настроить использования его. После этого все заработало

    Добавлено через 9 минут
    чуть незабыл, еще закоментировал строку: Options +FollowSymLinks
    в htaccess
     
Статус темы:
Закрыта.