[Помогите] Перестал работать wordpress.

Тема в разделе "Wordpress", создана пользователем evgenij2006, 30 июн 2009.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. evgenij2006

    evgenij2006 Постоялец

    Регистр.:
    26 авг 2007
    Сообщения:
    119
    Симпатии:
    3
    Перестал работать wordpress 2.8 рус., скачал с офф. сайта. Всегда всё было нормально. Но вчера заметил, что кроме главной страницы, ни одна страница не открывается (в том числе и wp-login.php), белый экран.
    Прописал в .htaccess:
    Код:
    php_value error_reporting 2039
    php_flag log_error off
    php_flag display errors on
    В логе ошибки увидел такую ошибку:
    На этом же хостинге стоят ещё 2 wordpress. Они работают нормально. Брал от них файл .htaccess и копировал в эту директорию. Ничего не помогло. Надеюсь на вашу помощь.
    Могу выложить файл php.ini. Он может задаваться для каждой директории отдельно.
     
  2. ozware

    ozware

    Регистр.:
    22 апр 2007
    Сообщения:
    327
    Симпатии:
    42
    попробуйте в index.php добавить такую команду:
    PHP:
    error_reporting(7);
    (вроде бы так пишется)

    а в .htaccess временно закомментируйте строчки c php_value и php_flag

    в логе на странице сайта по идее все должно быть написано
     
  3. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.564
    Симпатии:
    851
    Файл .htaccess лучше выложи.
    Админка открывается ?
     
  4. evgenij2006

    evgenij2006 Постоялец

    Регистр.:
    26 авг 2007
    Сообщения:
    119
    Симпатии:
    3
    Нет, админка не открываится. Вот код .htaccess:
    Код:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    #
    # Protect files and directories from prying eyes.
    <FilesMatch "\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
      Order allow,deny
    </FilesMatch>
    # Don't show directory listings for URLs which map to a directory.
    Options -Indexes
    # Follow symbolic links in this directory.
    Options +FollowSymLinks
    # Customized error messages.
    ErrorDocument 404 /index.php
    # Set the default handler.
    DirectoryIndex index.php
    # Override PHP settings. More in sites/default/settings.php
    # but the following cannot be changed at runtime.
    # PHP 4, Apache 1.
    <IfModule mod_php4.c>
      php_value magic_quotes_gpc                0
      php_value register_globals                0
      php_value session.auto_start              0
      php_value mbstring.http_input             pass
      php_value mbstring.http_output            pass
      php_value mbstring.encoding_translation   0
    </IfModule>
    # PHP 4, Apache 2.
    <IfModule sapi_apache2.c>
      php_value magic_quotes_gpc                0
      php_value register_globals                0
      php_value session.auto_start              0
      php_value mbstring.http_input             pass
      php_value mbstring.http_output            pass
      php_value mbstring.encoding_translation   0
    </IfModule>
    # PHP 5, Apache 1 and 2.
    <IfModule mod_php5.c>
      php_value magic_quotes_gpc                0
      php_value register_globals                0
      php_value session.auto_start              0
      php_value mbstring.http_input             pass
      php_value mbstring.http_output            pass
      php_value mbstring.encoding_translation   0
    </IfModule>
    # Requires mod_expires to be enabled.
    <IfModule mod_expires.c>
      # Enable expirations.
      ExpiresActive On
      # Cache all files for 2 weeks after access (A).
      ExpiresDefault A1209600
      # Do not cache dynamically generated pages.
      ExpiresByType text/html A1
    </IfModule>
    # Various rewrite rules.
    <IfModule mod_rewrite.c>
      RewriteEngine on
      # If your site can be accessed both with and without the 'www.' prefix, you
      # can use one of the following settings to redirect users to your preferred
      # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
      #
      # To redirect all users to access the site WITH the 'www.' prefix,
      # (http://example.com/... will be redirected to http://www.example.com/...)
      # adapt and uncomment the following:
      # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
      # RewriteRule ^(.*)$ http://www.example.com/$1 [L,R=301]
      #
      # To redirect all users to access the site WITHOUT the 'www.' prefix,
      # (http://www.example.com/... will be redirected to http://example.com/...)
      # adapt and uncomment the following:
      # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
      # RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]
      # Modify the RewriteBase if you are using Drupal in a subdirectory and
      # the rewrite rules are not working properly.
      #RewriteBase /drupal
      # Rewrite old-style URLs of the form 'node.php?id=x'.
      #RewriteCond %{REQUEST_FILENAME} !-f
      #RewriteCond %{REQUEST_FILENAME} !-d
      #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
      #RewriteRule node.php index.php?q=node/view/%1 [L]
      # Rewrite old-style URLs of the form 'module.php?mod=x'.
      #RewriteCond %{REQUEST_FILENAME} !-f
      #RewriteCond %{REQUEST_FILENAME} !-d
      #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
      #RewriteRule module.php index.php?q=%1 [L]
      # Rewrite current-style URLs of the form 'index.php?q=x'.
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    </IfModule>
    # $Id: .htaccess,v 1.81.2.3 2007/09/21 12:24:22 drumm Exp $
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    php_value error_reporting "E_ALL & ~E_NOTICE"
    php_flag log_error on
    php_flag display errors on
    Добавлено через 7 минут
    Пробовал не помогает. Вместо страниц, кроме главной, белый экран. Если же оставить строчки:
    Код:
    php_value error_reporting "E_ALL & ~E_NOTICE"
    php_flag log_error on
    php_flag display errors on
    то Internal Server Error 500.
     
  5. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.564
    Симпатии:
    851
    а вот так попробуй для начала:
    Код:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    
    А потом уже будешь изголяться и изучать правила mod_rewrite =)
    Права поставь на него хотябы 644, чтобы всякая муть тебе .htaccess не переписывала и не забивала бредятиной
     
  6. evgenij2006

    evgenij2006 Постоялец

    Регистр.:
    26 авг 2007
    Сообщения:
    119
    Симпатии:
    3
    Не понял. У меня то же самое прописано в .htaccess.
     
  7. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.564
    Симпатии:
    851
    Все остальное удали.
    Только эти строки должны быть в файле для того чтобы проверить работоспособность блога.
     
  8. tatams

    tatams

    Регистр.:
    15 май 2009
    Сообщения:
    501
    Симпатии:
    84
    Супер кеш часто тупит - попробуй отключить или удалить в вп-контент два файла его настроек и папку кеша.
     
    evgenij2006 нравится это.
  9. evgenij2006

    evgenij2006 Постоялец

    Регистр.:
    26 авг 2007
    Сообщения:
    119
    Симпатии:
    3
    Спасибо помогло.

    Добавлено через 26 секунд
    Нет не помогло.
     
  10. tatams

    tatams

    Регистр.:
    15 май 2009
    Сообщения:
    501
    Симпатии:
    84
    Сам долго мучился по сходной теме.
    Отдельный момент - супер-кешевые файлы всегда нужно делетить при переносе сайта на другой хостинг иначе сие.
     
Статус темы:
Закрыта.