[Помогите] Редактор в MU съедает код видео

Тема в разделе "Wordpress", создана пользователем Dьяменьший, 11 май 2009.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. Dьяменьший

    Dьяменьший

    Регистр.:
    7 сен 2008
    Сообщения:
    220
    Симпатии:
    212
    Не могу запостить видео в МЮ путем вставки кода. При сохранении или отправке поста, весь код исчезает.

    Кстати, кафеин в МЮ тоже не постит видео. А MyVideoBlog постит, он вставляет такую конструкцию:
    Код:
    <!--videoplayer--> (код видео) <!--endvideoplayer-->
    Попробовал сделать так вручную, не помогло: осталась только сама эта конструкция, весь код внутри съело. Значит, MyVideoBlog постит в обход редактора...

    В общем: как запостить видео МЮ? Может, нужно какой-то плагин использовать?
     
  2. Dьяменьший

    Dьяменьший

    Регистр.:
    7 сен 2008
    Сообщения:
    220
    Симпатии:
    212
    Проблема решена

    Сам отвечаю на свой вопрос. Может, кому-нибудь поможет.

    Не получив ответа, залез на буржуйские форумы. И обнаружил, что проблема очень распространенная и злободневная. Оказывается, это сделано специально, в целях безопасности, для того чтобы юзеры не занесли с embedded какую-нибудь гадость. Но если МЮ чисто ваш и используется чтобы не покупать кучу доменов, то этой защитой можно пренебречь.

    Вся эта фигня лежит в файле kses.php Открываем его и редактируем что надо...

    Есть готовые решения, например, http://mu.wordpress.org/forums/topic/1964/page/2
    Но этот плагин помогает вставлять только видео, а чтобы МЮ не резал яваскрипт, нужно этот плагин еще немного доработать или залезть прямо в вышеуказанный файл.

    Пользуйтесь на здоровье )
     
Статус темы:
Закрыта.