1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

траблы с SEO, mod_rewrite

Тема в разделе "Joomla", создана пользователем azul, 8 май 2009.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, NightHunter
  1. azul

    azul Постоялец

    Регистр.:
    16 дек 2007
    Сообщения:
    80
    Симпатии:
    6
    Добрый

    возникла проблемка с СЕО
    установил sh404SEF. после настройки и включения компонента, работает нормально только главная страница. остальные с проблемами думаю что с css, не отображается дизайн.
    Отключил компонент и включил стандартный SEO от джумы с включеным mod_rewrite. Та же проблема. что может быть? .htaccess?

    ps: стоит Джум 1.5.10
     
  2. AndrewDK

    AndrewDK

    Регистр.:
    8 фев 2009
    Сообщения:
    247
    Симпатии:
    58
    в sh404SEF зайди в компонент и увидишь на синем фоне (полоске) надпись. Не помню дословно, но там будет написано нажми сюда чтобы включить расширенный режим. Когда нажмешь появится надпись
    Click here to switch to standard display (with only main parameters)
    и больше возможностей.

    Переходи в конфигурацию -> расширенные и в Режим
    Перезаписи (Rewriting) укажи исп. .htaccess (mod_rew). Там по умолчанию стоит другое. И все будет работать.
     
  3. azul

    azul Постоялец

    Регистр.:
    16 дек 2007
    Сообщения:
    80
    Симпатии:
    6
    Спасибо за совет. Меня насторожило что не мог изменить не только в sh404SEF но и со стандартным SEO от джумы с включеным mod_rewrite. Подключил хостера и он просто сказал в .htaccess отключить строку CharsetDisable On. Помогло. теперь и sh404SEF и стандартный от джумы работают!!
     
  4. Aggilus

    Aggilus Создатель

    Регистр.:
    18 окт 2008
    Сообщения:
    21
    Симпатии:
    0
    На всех движках сталкивался с проблемой реврайта. Лень было разбиратся, но таки пришлось. ПОковырял настройки сервера, все работает. В апаче просто включить нужно
     
  5. azul

    azul Постоялец

    Регистр.:
    16 дек 2007
    Сообщения:
    80
    Симпатии:
    6
    Апачи со старта у хостера включен. на оф. сайте джумлы говорят проверить в первую очередь совместимость хостера и апачи. и потом вот этот проблематичный .htaccess

    На данный этап проблема решена. как и объяснил выше, нужно одну строку в .htaccess отключить
     
  6. ivanoff12

    ivanoff12 Создатель

    Регистр.:
    22 окт 2008
    Сообщения:
    41
    Симпатии:
    12
    ну а самое простое решение пользовать дистрибутив с уже настроенным сео и сэкономить время на настройку.

    еще есть такая хорошая штука как сео патч - я его даже в квикстарт шаба от шейп5 запихнул - и вуаля - все работает - чпу и сео настроены, а я даже палец о палец не стукнул в этом направлении и не знаю как -

    а в свое время я тоже в каком то сеошном компоненте здорово потерялся - не хотел он работать как я ни танцевал над ним с бубном...
     
Статус темы:
Закрыта.