Помощь поиск на DLE 7.5 сайте

Тема в разделе "DLE", создана пользователем Abi3, 21 апр 2009.

Информация :
Актуальная версия DataLife Engine 12.0
( Final Release v.12.0 | Скачать DataLife Engine | Скачать 12.0 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.3 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. Abi3

    Abi3 Создатель

    Регистр.:
    10 сен 2008
    Сообщения:
    47
    Симпатии:
    7
    стоит движек 7,5 mid
    проблема в следующем при вводе любого слова в поиск отображается страница поиска, ниже написано "По Вашему запросу найдено 12 ответов (Результаты запроса 1 - 12) :"
    а ниже самого списка найденных просто нет...
    прикол в том, что Опера, Ие, Гугла не выдает результаты поиска и не выводит для этого окна нижней части шаблона
    а вот Лиса без проблем показывает все...

    Проверялось на стандартном и родном шаблоне сайта...
    сохранил для оперы и Лисы исходный код страницы с результатами поиска. В опере просто пустые строчки с 700 вместо кода
    Лиса:
    document.onkeydown = reg_keys;

    </script>

    <table width="100%" border="0" cellspacing="0" cellpadding="0">
    Опера
    document.onkeydown = reg_keys;

    </script></div>

    Если кто-то сталкивался с таким, подскажите как исправить
     
  2. GauraStyle

    GauraStyle Kot

    Регистр.:
    13 фев 2007
    Сообщения:
    1.500
    Симпатии:
    920
    Хм, есть несколько вариантов.
    1. Это в Настройках системы-> Поиском могут пользоваться лиш зарегистрированые юзверы.
    2. Это кривость риппа.
    Два года назад писалося в Правилах, что или указывайте сылку на источник где смотреть или скрин делайте для просмотра, что бы каждый мог посмотреть, может у многих такая ошибка имееться и никто незнает как её решить или никто непользовался у себя на сайте поиском и несмотрел результат.
    :nezn:
     
  3. Abi3

    Abi3 Создатель

    Регистр.:
    10 сен 2008
    Сообщения:
    47
    Симпатии:
    7
    1)Поиск разрешен даже без авторизации
    пробывал и простой и подробный в настройках системы.
    2) Рипп тут не причем, поиск проверялся на стандартном шаблоне (Default) и на нескольких других, при этом search.tpl и searchresult.tpl у всех одинаковые.
    сайт carinfo.com.ua

    проблема наблюдается в Опере, ИЕ, Гугле .... Лиса спокойно отображает результаты поиска
     
  4. Abi3

    Abi3 Создатель

    Регистр.:
    10 сен 2008
    Сообщения:
    47
    Симпатии:
    7
    Верстка стандартного шаблона тоже не правильная ? Default, который идет вместе с движком... На всех шаблонах такая фигня с поиском...
    Какие еще могут быть варианты ? :(
     
  5. forbuc

    forbuc Создатель

    Регистр.:
    14 мар 2008
    Сообщения:
    31
    Симпатии:
    3
    Открой engine/modules/search.php, найди строку:

    document.onkeydown = reg_keys;

    после нее вставь:

    // end -->

    Думаю поможет :)
     
    Abi3 нравится это.
Статус темы:
Закрыта.