[Помогите] Кракозябры после переноса блога

Тема в разделе "Wordpress", создана пользователем Dmytr0, 19 апр 2009.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. Dmytr0

    Dmytr0

    Регистр.:
    11 авг 2008
    Сообщения:
    242
    Симпатии:
    34
    Перенес блог; посты, названия рубрик и тегов отображаются нормально, но некоторые ссылки, как можно увидеть на скрине, отображаются неправильно: главная, поиск, архив, #searchform. Подскажите пожалуйста, где и что исправить.
     
  2. g-prime

    g-prime איך בין גאָט

    Регистр.:
    11 авг 2008
    Сообщения:
    779
    Симпатии:
    1.131
    В .htaccess в корне сайта, пропишите AddDefaultCharset UTF-8, если не поможет: CharsetSourceEnc UTF-8
    И прочитай вдобавок эту статью, если не поможет первый вариант
     
    Dmytr0 нравится это.
  3. Dmytr0

    Dmytr0

    Регистр.:
    11 авг 2008
    Сообщения:
    242
    Симпатии:
    34
    AddDefaultCharset UTF-8 - никаких изменений.
    CharsetSourceEnc UTF-8 - Internal Server Error :D
    О скрипте: все так и есть, правил тему в блокноте, скрипт нашел за"бом"ленные сайдбар, футер и индекс. Одна беда: ссылка на удалялку BOM мертвая, как еще можно исправить файлы ?
     
  4. g-prime

    g-prime איך בין גאָט

    Регистр.:
    11 авг 2008
    Сообщения:
    779
    Симпатии:
    1.131
    Скачай Notepad++ и отредактируй нормально файлы шаблона и будет тебе счастье!
     
  5. zek_rs

    zek_rs Создатель

    Регистр.:
    16 янв 2009
    Сообщения:
    42
    Симпатии:
    4
    Да у меня была похожая проблема, попробуй пересохранить файлы шаблона сайта в кодировку UTF-8 без функции BOM (это если открыть блокнотом файл php через F4 total cmd)
     
  6. Dmytr0

    Dmytr0

    Регистр.:
    11 авг 2008
    Сообщения:
    242
    Симпатии:
    34
    Каюсь, был невнимателен, подумал, что Notepad2 сам поудаляет эти BOM'ы, как оказалось, всего-то нужно было поставить флажок на File-Encoding-UTF-8. Большое спасибо!
     
Статус темы:
Закрыта.