Домашний сервер на ХР

Тема в разделе "Администрирование серверов", создана пользователем Смоленский, 1 апр 2009.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Задачи:
    Работа с скриптами, cms, отладка, модернизирование, подгонка, тюнинг на домашнем пк, без каких либо сверх задач.

    Вопросы:
    1. Какую версию apache лучше использовать для XP ?
    2. Как лучше подключать php: модуль или CGI ?

    Просьба к опытным Братьям:
    Если есть конфиг apache который оптимально подходит под мои задачи, полноценно поддерживает htaccess, mod rewrite, не возникает проблем с кодировкой. Выложите пожалуйста здесь с указанием версии apache.

    Спасибо за помощь и понимание.
     
  2. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    Поставь поначалу готовую сборку.
    На ней упражняйся с конфигами.
    Как осилишь, сам поймёшь что тебе нужно и как это поставить.
     
  3. 2pick

    2pick Постоялец

    Регистр.:
    15 мар 2009
    Сообщения:
    102
    Симпатии:
    29
    Денвер ставь
    denwer.ru
     
  4. dotsenko

    dotsenko

    Регистр.:
    27 дек 2006
    Сообщения:
    233
    Симпатии:
    106
    я бы советовал xampp последняя версия стабильная и фтп может запустить
     
  5. advil

    advil Постоялец

    Регистр.:
    12 янв 2009
    Сообщения:
    118
    Симпатии:
    21
    Хм, уж если на то пошло, то я бы посоветовал TopServer, прост в обращении и подходит под все виды скриптов. И так же с нетерпением жду выхода Денвер-4, думаю вообще штука клевая будет.

    А если уж сам решил всё таки настраивать, лучше почитай статей в инете как настраивается сервер, их полно, а потом уж если всё поймешь, думаю и сам разберешься что лучше всего поставить, что с чем соеденить.
     
  6. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Стоит apache 1.3.34, php 4.4.9, MySQL 5.1. Но не устраивает несколько вещей mod_rewrite странно работает (на одних скриптах чпу отлично работает, на других вообще не работает), поддержка htaccess кривая (указываю кодировку, серверу пофиг), php не хочет несколько модулей поддерживать хотя они находятся в каталоге в котором лежат и остальные модули). Вообщем по этому и попросил конфиг апача. Denwer не рассматриваю и не спрашивайте почему, сам не знаю.

    Плюс начитался разной фигни, теперь одни сомнения. Например apache v1.* лучше для linux, apache 2.* лучше для xp и т.д. Что php лучше подключать как CGI, но когда подключил он раз в 10 медленнее стал работать.
     
  7. Mur

    Mur Постоялец

    Регистр.:
    4 апр 2008
    Сообщения:
    78
    Симпатии:
    23
    Уже больше года с удовольствием пользуюсь WOS portable. И бесплатно и версии почти всех популярных скриптов обновляют.
     
  8. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    Ставь apache 2 - нормально работает как под win, так и под linux.
    PHP4 - прошлый век, уже год как прекращено развитие, уже 6 не за горами.

    Под CGI ясен перец будет работать медленнее, чем mod_php.

    Если решишься ставить Linux, подскажу конкретнее, а что такое Windows я забыл года 4 назад.
     
    Смоленский нравится это.
  9. Demon425

    Demon425

    Регистр.:
    9 июл 2008
    Сообщения:
    439
    Симпатии:
    96
    _http://rghost.ru/161338
    _http://www.rapidshare.ru/972098
    _http://dump.ru/file/2267816

    FastWebServer 3.0

    nginx 0.6.35
    Apache 2.2.4
    PHP 5.2.4
    Zend Engine 2.2.0
    Zend Optimizer v3.3.0
    Zend Extension Manager v1.2.0
    ionCube PHP Loader v3.1.32
    MySQL 5.0.45
    phpMyAdmin 2.6.1
    Sendmail

    быстрый, простой, всё есть, сам юзаю )
     
  10. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Поставил, получилось в следующей конфигурации: Apache 2.0.63, PHP Version 5.2.9-1 (в скриптах заработали некоторые функции), MySQL 5.0.51 (стояло), ZendOptimizer-3.3.3

    Осталось найти напильник к конфигам и будет счастье :)
     
Статус темы:
Закрыта.