Error: the php zip extension is not available

Тема в разделе "PHP", создана пользователем hoopeer, 28 мар 2009.

Статус темы:
Закрыта.
Модераторы: latteo
  1. hoopeer

    hoopeer

    Регистр.:
    10 фев 2007
    Сообщения:
    807
    Симпатии:
    250
    На Денвере вот такая ошибка вылетает:
    Error: the php zip extension is not available

    Я так понимаю, что не хватает zip модуля. Подскажите, как его установить? :thenks:
     
  2. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    Скачать php_zip.dll (гугл в помощь), поместить его в папку расширений PHP и прописать в php.ini
     
    hoopeer нравится это.
  3. ne0zx

    ne0zx

    Регистр.:
    1 ноя 2008
    Сообщения:
    212
    Симпатии:
    74
    hoopeer нравится это.
  4. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    ne0zx а компилить ты его будешь?

    PECL - это репозиторий исходников модулей под никсы. Для win есть отдельный репозиторий скомпилированных ddl pecl4win.php.netно он давненько закрыт.
     
  5. hoopeer

    hoopeer

    Регистр.:
    10 фев 2007
    Сообщения:
    807
    Симпатии:
    250
    Спасибо, что так быстро ответили :)

    Я делал так:
    раскомментировал строку в php.ini
    extension=php_zip.dll

    В папку ext залил php_zip.dll
    Перегрузил денвер, выдало ошибку, что не хватает файла php4ts.dll Нашел в гугле и залил php4ts.dll, перегрузил Денвер теперь выдает такую ошибку:
    "точка входа в процедуру -zend_list_delete не найдена в библиотеке DLL php4ts.dll"

    ne0zx а чего делать с этим архивом? Сорри, что туплю, просто только начал изучать всё это дело.
     
  6. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    Найди php_zip.dll под свою версию PHP.

    Забей, ничего ты с ним не сделаешь.
     
    hoopeer нравится это.
  7. hoopeer

    hoopeer

    Регистр.:
    10 фев 2007
    Сообщения:
    807
    Симпатии:
    250
    Точно помогло, нашёл другой php_zip.dll и заработало :yahoo: PHP_Master Спасибо. Тему можно закрывать.
     
Статус темы:
Закрыта.