Проблема с register_globals Off в php.ini

Тема в разделе "Mod Rewrite / htaccess / ЧПУ", создана пользователем incident, 25 мар 2009.

Статус темы:
Закрыта.
  1. incident

    incident Создатель

    Регистр.:
    29 апр 2008
    Сообщения:
    15
    Симпатии:
    0
    Проблема с register_globals Off
    В php.ini прописано register_globals Off
    в корневой директории сайта создал файл .htaccess в котором прописано php_flag register_globals On

    .htacces работает а вот директива register_globals -- нет.

    Сделал рестарт httpd, сайт не работает. В чем может быть проблема?
     
  2. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    PHP точно установлен как mod_php?
     
  3. incident

    incident Создатель

    Регистр.:
    29 апр 2008
    Сообщения:
    15
    Симпатии:
    0
    Да установлен как mod_php

    Человек предлагает прописать вот это в .htaccess

    AuthType Basic
    AuthName "restricted area"
    AuthUserFile /usr/local/var/www/html/.htpasses
    <Limit POST>
    require valid-user
    </Limit>
    .htaccess

    AuthType Basic
    AuthUserFile /path/to/where/you/want/to/store/the/password/file/.htpasswd
    AuthName vQadmin
    require valid-user
    satisfy any
    chown apache .htaccess
    chmod 644 .htaccess
    htpasswd -bc /path/to/where/you/want/to/store/the/password/file/.htpasswd admin admin_password

    chmod 644 /path/to/where/you/want/to/store/the/password/file/.htpasswd
    /home/root/html/hostname/cgi-bin/

    Но еще не пробовал. Вечером буду разбиратся :confused:
     
  4. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    Это авторизация, не понимаю как она поможет с твоей проблемой.
     
  5. incident

    incident Создатель

    Регистр.:
    29 апр 2008
    Сообщения:
    15
    Симпатии:
    0
    Тоесть это даже нет смысла ковырять?! А авторизация чего?

    Тогда есть какието мысли, как мне подружить сайт использующий глобальные переменные с выключенным register_globals в php.ini?!
     
  6. PHP_Master

    PHP_Master

    Регистр.:
    3 фев 2008
    Сообщения:
    2.647
    Симпатии:
    590
    Если используется действительно mod_php, то как правило "php_value register_globals 1" или "php_flag register_globals On" достаточно для включения этого режима.
    Покажи свой phpinfo();
     
  7. incident

    incident Создатель

    Регистр.:
    29 апр 2008
    Сообщения:
    15
    Симпатии:
    0
  8. incident

    incident Создатель

    Регистр.:
    29 апр 2008
    Сообщения:
    15
    Симпатии:
    0
    Опишу проблему еще раз.

    В настройках php.ini register_globals стоит On. До определенного времени меня это не трогало, пока я не стал инсталлировать сайт который требует в обязательном порядке выключить r._g. Я выключил в php.ini, сделал рестарт httpd, проверил работоспособность сайтов, большие сайты работают отлично, ничего не случилось.
    Есть два маленьких сайта где куча php файлов, они инклюдят друг друга в зависимости от выбранного параметра меню.

    В каталоге одного из этих сайтов я создал .htaccess в котором прописал php_flag register_globals On (.htaccess работают 100%, т. е. в httpd.conf прописано AllowOverride Options FileInfo AuthConfig Limit)

    Сделал рестарт httpd и сайт неработает.
    Исходя из этого стало ясно что .htaccess php_flag register_globals On не работает.

    Вот я и непонимаю в чем проблема :)
     
  9. waldicom

    waldicom Создатель

    Регистр.:
    15 мар 2009
    Сообщения:
    41
    Симпатии:
    3
    А если прописать AllowOverride all, для теста?
     
  10. incident

    incident Создатель

    Регистр.:
    29 апр 2008
    Сообщения:
    15
    Симпатии:
    0
    Пробовал, ничего не дает. Хотя сами .htaccess работают
     
Статус темы:
Закрыта.