Linux and Xorg (rus keyboards)

Тема в разделе "Десктопный Linux", создана пользователем symbolz, 23 мар 2009.

Статус темы:
Закрыта.
Модераторы: Цукер
  1. symbolz

    symbolz Постоялец

    Регистр.:
    26 янв 2008
    Сообщения:
    75
    Симпатии:
    14
    День добрый!
    Решил поделиться одной приятной штукой. У меня в Ubunte 8.10, когда прописываю в xorg.conf работать с двумя расскладками, то не работает. Мучался очень долго, но нашел решение

    можно задавать для каждого пользователя разные расскладки клавиатуры
    достататочно создать файлик в домашней директории .Xkbmap
    и его содержимое
    -option grp:alt_shift_toggle,grp:switch,grp_led:scroll us,ru

    Вообщем мне помогло
    :yahoo:
     
  2. baddan

    baddan

    Регистр.:
    14 мар 2008
    Сообщения:
    355
    Симпатии:
    42
    ищу решение проблемы по разрешению монитора, многие говорят что это проблема HAL gnom щас стал хранить конфиги в собственных местах xml создает и плюет на xorg.conf

    решение говорят стереть xml
    либо проставить в xorg
    Option "AutoAddDevices" "False"
    секция не помню как называется ну вот собственно както так.

    так как хорг и за раскладки отвечает. вобщем ну вы поняли :) HAL.
     
  3. AccessForbidden

    AccessForbidden

    Регистр.:
    5 янв 2009
    Сообщения:
    324
    Симпатии:
    57
    А теперь переключись на русский и нажми Ctrl+C в каком нибудь терминале.
    Или нажми не alt_shift, а наоброт - как в привычном Windows (работает и так, и наборот). В общем ты будешь приятно удивлен. Ибо все это не работает :)
    Отключай нафиг xkb и правь xorg.conf
    Код:
    Section "InputDevice"
            Identifier      "Generic Keyboard"
            Driver          "kbd"
            Option          "CoreKeyboard"
            Option          "XkbRules"      "xorg"
            Option          "XkbModel"      "pc104"
            Option          "XkbLayout"     "us,ru"
            Option          "XkbVariant"    ",winkeys"
            Option          "XkbOptions"    "grp_led:num,grp:alt_shift_toggle"
    EndSection
    
    Тогда все заработает.
     
  4. symbolz

    symbolz Постоялец

    Регистр.:
    26 янв 2008
    Сообщения:
    75
    Симпатии:
    14

    Проделал все что ты сказал и был приятно удивлен, что у меня не такое поведение ))))
    В xorg.conf у меня даже секции нету Section "InputDevice"
    а только маленький файлик в хомяке ) И работает как часы, без каких либо претензий.
    Прийду домой и попробую этот вариант InputDevice
    потом отпишу. завелось так или нет.
     
Статус темы:
Закрыта.