1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

News Fader + Multithumb не правильно генерирует ссылку на новость?

Тема в разделе "Joomla", создана пользователем new_forward, 20 мар 2009.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, NightHunter
  1. new_forward

    new_forward

    Регистр.:
    5 май 2008
    Сообщения:
    668
    Симпатии:
    44
    Ситуация такая 10 популярных новостей выводятся на главной странице через модуль News Fader но при этом включен мамбот Multithumb и получается так например что ссылка "Подробнее" правильная:

    Код:
    http://www.mysite.ru/index.php?option=com_content&task=view&id=9&Itemid=2
    а ссылка через картину чуть-чуть не такая с другим Itemid

    Код:
    http://www.mysite.ru/index.php?option=com_content&task=view&id=9&Itemid=1
    Мне кажется что это мамбот Multithumb неправильно ее генерирует или Itemid теряется и он еденицу ставит...

    Подскажите в чем проблема? :bc:
     
  2. emone

    emone Постоялец

    Регистр.:
    1 сен 2007
    Сообщения:
    133
    Симпатии:
    38
    У тебя джумла с линейки 1.0.15 ? мультитамб кажись ток на этой версии работает, так вот какую именно версию ты используеш мамбота ? попробуй обновиться на версию выше мамбота или ниже ... или альтернативный плагин используй.
    Просто трудно так сказать сразу почему такая ошибка очень мало описания.
    П.С. не пойму причем здесь мультитумб к статьям ? он же тока создает тумбы картинок?... или у тебя ссилка на новость? попробуй отключить картинку и не делай ее ссилкой на всю новтсьь а используй допустим Тайтл навзания как ссилка ?
     
  3. new_forward

    new_forward

    Регистр.:
    5 май 2008
    Сообщения:
    668
    Симпатии:
    44
    1. Joomla 1.0
    2. Multithumb 2.0 beta 1.3

    Ссылка через картинку имеет такой вид:
    Код:
    <a href="index.php?option=com_content&amp;task=view&amp;id=8&amp;Itemid=1" title=""><img class='multithumb'  src="http://www.mysite.ru/mambots/content/multithumb/thumbs/b.150.96.16777215.0..stories.fruit.pears.jpg"width="150" height="96" style='border: 1px solid #CCCCCC;'  align='right'   hspace='6' alt='' title='' border='' /></a>
    Только что попробовал вывести модуль в другом разделе меню ссылка поменялась на ссылку этого раздела, другими словами фотографии автоматически присваивается ссылка той страницы где выводится модуль...Я даже исходный код страницы посмотрел точно так оно и есть...

    Может это News Fader вытворяет запутаться можно блин...:nezn:
     
  4. emone

    emone Постоялец

    Регистр.:
    1 сен 2007
    Сообщения:
    133
    Симпатии:
    38
    ану-ка отпубликуй мулльтитамб. и установи этот тумбер mosimagesresize.zip попробуй с ним .. и увидиш где тогда грабли ... и в каком именно комопненте\плагине конфликт.
    П.С. и как вариант говорю .. в настрйоках мультитумба отключи параметр "Делать картинку ссилкой на контент" и будет вам счастье :)
     
    new_forward нравится это.
  5. new_forward

    new_forward

    Регистр.:
    5 май 2008
    Сообщения:
    668
    Симпатии:
    44
    Да ссылку он выводить на контент не может, жаль конечно спасибо.:)
     
Статус темы:
Закрыта.