пропадают ссылки в таблице в IE 7

Тема в разделе "Веб-дизайн", создана пользователем fafee, 12 мар 2009.

Статус темы:
Закрыта.
Модераторы: zek24
  1. fafee

    fafee Постоялец

    Регистр.:
    4 окт 2008
    Сообщения:
    92
    Симпатии:
    0
    Добрый день. Верстал как водится в огнелисе, открыл IE 7 и вошел в экстаз - из трех ссылок в таблице (две из которых картинками в диве, а одна текстом в ячейке) не работает ни одна.
    картинки есть, текст есть, ничего не кликается. как такое происходит я не понимаю. менял все, что только можно. результат - тот же.
    HTML:
    
     <table cellpadding='0' cellspacing='0' align='right' width='150'>
         <tr>
            <td align='right'>
              <div style='margin: 0 16 0 0'>
                <a href='ссылка1' title='текст1'>
                   <img src='имадж1' border='0'>
                </a>
               <a href='ссылка2' title='текст2'>
                   <img src='имадж2' border='0'>
               </a>
             </div>
          </td>
        </tr>
        <tr>
         <td>
           <a href='ссылка3'>
             Текст3
           </a>
         &nbsp;&nbsp;&nbsp;
        </td>
      </tr>
    </table>
    
    как победить?
    Спасибо.
     
  2. t0os

    t0os

    Регистр.:
    21 окт 2007
    Сообщения:
    284
    Симпатии:
    36
    попробуйте из тега <img> убрать. и приведите полный код страницы, если не сложно.
     
  3. fafee

    fafee Постоялец

    Регистр.:
    4 окт 2008
    Сообщения:
    92
    Симпатии:
    0
    PHP:
    {include file='header.tpl'}

    <
    div class='page_header'><a href='{$url->url_create('profile', $owner->user_info.user_username)}'>{$owner->user_info.user_username}</a» {$blog2}</div>
    <
    br>

    {* 
    SHOW NO ENTRIES MESSAGE IF NECESSARY *}
    {if 
    $total_blogentries == 0}
      <
    table cellpadding='0' cellspacing='0'>
      <
    tr><td class='result'>
        <
    img src='./images/icons/bulb22.gif' border='0' class='icon'> <b><a href='{$url->url_create('profile', $owner->user_info.user_username)}'>{$owner->user_info.user_username}</a></b> {$blog3}
      </
    td></tr>
      </
    table>
    {/if}

    {* 
    SHOW BLOG ENTRIES *}
         <
    table cellpadding='0' cellspacing='0' align='right' width='150'>
         {if 
    $owner->user_info.user_username == $user->user_info.user_username}
         <
    tr><td align='right'>
         <
    div style='margin: 0 16 0 0'><a href='user_blog_newentry.php' title='заметить'>
         <
    img src='./images/icons/newentry16.gif' border='0'></a>
         <
    a href='user_blog_editentry.php?' title='настройки'>
         <
    img src='./images/icons/admin_setting16.gif' border='0'></a></div>
         </
    td></tr>{/if}
         <
    tr><td>
         
        
         <
    a href='user_friends_blog.php'>Все</a>
         &
    nbsp;&nbsp;&nbsp;
     
        </
    td></tr></table>

    {include 
    file='footer.tpl'}
    Добавлено через 44 минуты
    кажется начал понимать в чем проблема - получается что у меня на одном уровне по горизонтали две таблицы, и осел отрубает ссылки в правой.
    а если сдвинуть их одна под другую все ок.
    вот такие пироги с котятами))))
     
Статус темы:
Закрыта.