Обратился в хостинг HC, чтобы поставили модули Perl

Тема в разделе "Администрирование серверов", создана пользователем bva, 12 мар 2009.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. bva

    bva Постоялец

    Регистр.:
    30 мар 2007
    Сообщения:
    105
    Симпатии:
    5
    Обратился в хостинг (мой сервер VPS+Plesk без root доступа) Мне нужны были эти модули. то есть из этого списка:

    *естественно я не был против, того, что версии могут быть новее, чем мои.

    что нужно было.
    PHP:
    ModuleArchive::Tar            Version1.30
    Module
    Archive::Zip            Version1.18
    Module
    Bundle::CPAN            Version1.855
    Module
    CGI             Version3.28
    Module
    CPAN            Version1.8802
    Module
    Compress::Raw::Zlib             Version2.004
    Module
    Compress::Zlib          Version2.004
    Module
    Cwd             Version3.24
    Module
    Digest::SHA             Version5.44
    Module
    ExtUtils::CBuilder              Version0.18
    Module
    File::HomeDir           Version0.64
    Module
    File::Temp              Version0.18
    Module
    File::Which             Version0.05
    Module
    IO::Compress::Base              Version2.004
    Module
    IO::Compress::Zlib              Version:
    Module: List::Util              Version1.19
    Module
    Module::Build           Version0.2807
    Module
    Net             Version:
    ModulePerl            Version5.8.6
    Module
    Term::ReadLine          Version1.01
    Module
    Test::Harness           Version2.64
    Module
    Test::Simple            Version0.70
    Module
    Text::Glob              Version0.07
    Module
    Unicode::Map8           Version0.12
    Module
    Unicode::String         Version2.09
    Module
    XML::LibXML             Version1.62
    Module
    XML::LibXML::Common             Version0.13
    Module
    XML::NamespaceSupport           Version1.09
    Module
    XML::SAX                Version0.15
    Module
    YAML            Version0.62
    до того, как обратился в суппорт на сервере стояло:
    PHP:
    ModuleArchive::Zip            Version1.26
    Module
    CPAN            Version1.9304
    Module
    ExtUtils::MakeMaker             Version6.48
    Module
    File::HomeDir           Version0.82
    Module
    File::Temp              Version0.21
    Module
    File::Which             Version0.05
    Module
    : List::Util              Version1.19
    Module
    Module::Build           Version0.32
    Module
    Net             Version:
    ModulePackage::Constants              Version0.02
    Module
    Perl            Version5.8.8
    Module
    Term::ReadLine          Version1.02
    Module
    Test::Harness           Version3.16
    Module
    Test::Simple            Version0.86
    Module
    Text::Glob              Version0.08
    Module
    YAML            Version0.68
    а теперь внимание :mad: то, что сейчас поставили из поддержки столько модулей, о которых половину я не просил...

    PHP:
    [COLOR="red"]Ваша заявка выполнена.
    В данный момент установлены следуюшие модули:[/COLOR]

    ModuleApache::ASP             Version2.61
    Module
    Archive::Zip            Version1.26
    Module
    Attribute::Handlers             Version0.81
    Module
    AutoLoader              Version5.68
    Module
    B::Debug                Version1.11
    Module
    B::Lint         Version1.11
    Module
    CGI             Version3.34
    Module
    CPAN            Version1.9304
    Module
    Compress::Raw::Zlib             Version2.015
    Module
    Compress::Zlib          Version2.015
    Module
    Cwd             Version3.29
    Module
    Digest          Version1.15
    Module
    Digest::SHA             Version5.47
    Module
    Exporter                Version5.63
    Module
    ExtUtils::CBuilder              Version0.24
    Module
    ExtUtils::Command               Version1.16
    Module
    ExtUtils::Install               Version1.52
    Module
    ExtUtils::MakeMaker             Version6.48
    Module
    ExtUtils::Manifest              Version1.56
    Module
    File::HomeDir           Version0.82
    Module
    File::Path              Version2.07
    Module
    File::Temp              Version0.21
    Module
    File::Which             Version0.05
    Module
    Filter::Simple          Version0.84
    Module
    Font::AFM               Version1.20
    Module
    FreezeThaw              Version0.45
    Module
    Getopt::Long            Version2.37
    Module
    HTML-Format             Version:
    ModuleHTML-Tree               Version:
    ModuleHTML::Tagset            Version3.20
    Module
    IO::Compress::Base              Version2.015
    Module
    IO::Compress::Zlib              Version:
    ModuleLWP             Version5.825
    Module
    : List::Util              Version1.19
    Module
    Locale-Maketext         Version:
    ModuleMath::BigInt            Version1.89
    Module
    Math::BigRat            Version0.22
    Module
    Module::Build           Version0.32
    Module
    Module::Pluggable               Version3.8
    Module
    Net             Version:
    ModuleNet::Ping               Version2.35
    Module
    Package::Constants              Version0.02
    Module
    Perl            Version5.8.8
    Module
    Pod             Version:
    ModulePod::Escapes            Version1.04
    Module
    Pod::Parser             Version1.37
    Module
    Pod::Perldoc            Version3.15
    Module
    Pod::Simple             Version3.07
    Module
    Safe            Version2.16
    Module
    SelfLoader              Version1.17
    Module
    Shell           Version0.72
    Module
    : Switch          Version2.14
    Module
    Term::ANSIColor         Version2.00
    Module
    Term::Cap               Version1.12
    Module
    Term::ReadLine          Version1.02
    Module
    Test::Harness           Version3.16
    Module
    Test::Harness::Straps           Version0.30
    Module
    Test::Simple            Version0.86
    Module
    Text            Version:
    ModuleText::Balanced          Version2.0.0
    Module
    Text::Glob              Version0.08
    Module
    Text::ParseWords                Version3.27
    Module
    Thread::Semaphore               Version2.09
    Module
    Tie::RefHash            Version1.38
    Module
    Time::Local             Version1.1901
    Module
    URI             Version1.37
    Module
    Unicode::String         Version2.09
    Module
    XML::LibXML             Version1.69
    Module
    XML::SAX                Version0.96
    Module
    XSLoader                Version0.10
    Module
    YAML            Version0.68
    Module
    autodie         Version1.999
    Module
    base            Version2.12
    Module
    bignum          Version0.23
    Module
    constant                Version1.17
    Module
    version         Version0.76

    так у меня вопрос, большое количество установленных не нужных модулей как влияет на работу сервера в будущем? тормоза могу быть? память оперативную жрут? производительность в целом? конфликт между собой? помимо того, что они место съедают жёсткого диска....

    ну и естественно, напишите мне комманду, как их удалить, не нужные. чтобы я им написал как их удалять :nezn:


    :thenks:

    о наличии установленных на хостинге узнавал этим скриптом.
    http://hosting.nic.ru/support/perl/#3
     
  2. sens7

    sens7 Постоялец

    Регистр.:
    9 авг 2008
    Сообщения:
    51
    Симпатии:
    7
    веротяно поставили завимости
    которые требовали модули =)

    память и проц не жрут )
    места чуть-чуть
     
  3. bva

    bva Постоялец

    Регистр.:
    30 мар 2007
    Сообщения:
    105
    Симпатии:
    5
    они из списка не поставили всё, что я просил...

    PHP:
    ModuleArchive::Tar            Version1.30

    Module
    Bundle::CPAN            Version1.855 

    Module
    XML::LibXML::Common             Version0.13
    Module
    XML::NamespaceSupport           Version1.09
    p.s.
    а как они о зависимостьях узнают? :-]
    в пункте где я писал выше что нужно было. этот полный список я взял с сервера, которого переношу сайт. по идеи значит это достаточно было... или нет?!
     
  4. XeonN

    XeonN

    Регистр.:
    13 ноя 2006
    Сообщения:
    369
    Симпатии:
    150
    Не не достаточно, почти каждый пакет тянет за собой несколько других, на скорость работы практически не влияеет.
    А что-бы не возникало таких вопросов ставьте сами все пакеты :)

    Могу предположить что если стоит плеск, то там есть панелька от виртуозо, с нее и ставьте если нет опыта работы в ssh да конечно жутко не удобно но все-же :)
    Она сама все зависимые пакеты загрузит

    При установке из rpm ругаеться он что эму надо что-то :)
     
    bva нравится это.
  5. bva

    bva Постоялец

    Регистр.:
    30 мар 2007
    Сообщения:
    105
    Симпатии:
    5
    XeonN
    я пытался коммандами, через встроенный SSH в контрол. панель, но Плеск без root доступа (
    Пришлось через тех. поддержку!

    Сейчас всё установили и только этих нет среди списка...
    Здравствуйте.

    К сожалению мы не можем вам ответить почему скрипт не отображает установленные
    модули.
    Ёще раз повторюсь, требуемые модули на сервере установлены.
    Не отображаются эти: через этот скрипт смотрю, что стоит http://hosting.nic.ru/support/perl/#3
    > > Module: XML::LibXML::Common Version: 0.13
    > > Module: XML::NamespaceSupport Version: 1.09
    > > Module: Bundle::CPAN Version: 1.855


    такое может, быть чтобы не отображались среди прочих? :eek:
     
Статус темы:
Закрыта.