[Помогите] Исчезли страницы, как?

Тема в разделе "Wordpress", создана пользователем monia, 10 мар 2009.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. monia

    monia

    Регистр.:
    27 июл 2007
    Сообщения:
    421
    Симпатии:
    68
    Сегодня обнаружил, что на моем блоге исчезли все отдельные страницы с постами (кроме последнего поста - самого свежего). Сами посты, как положено по 10 штук присутствуют, а вот если кликаем на название поста нас перекидывает не на отдельную страницу, где находится полная запись и можно оставлять каменты, а на страницу "Извините, ничего не найдено".
    На блоге ничего не менялось. НО! Закинул вчера еще один домен на этот же хост и установил там еще один wordpress, т.е. теперь на одном хостинге 2 домена=2 блога. Могло это быть причиной того, что я описал? Или что вообще могло произойти, может у кого-то так было? В настройках постоянных ссылок установлено: Месяц и название - хttp://blog.ru/2009/03/sample-post/
     
  2. BFox

    BFox

    Регистр.:
    11 янв 2008
    Сообщения:
    368
    Симпатии:
    65
    Ты разные базы данных создал? Если все в одну запихнул, то проверь префиксы, разные ли они. Посмотри в базе данных есть ли твои посты
     
  3. yroc

    yroc

    Регистр.:
    13 мар 2007
    Сообщения:
    174
    Симпатии:
    45
    Пару раз было такое. Это точно проблема базы данных. Первый раз почему-то убило напрочь таблицу wp_posts. Восстановил из бекапа.
    Во втором случае после каких-то работ проводимых хостером все таблицы вроде были целыми, но посты не отображались. Решилось нажатием в БД кнопочки "восстановить таблицу"
     
  4. monia

    monia

    Регистр.:
    27 июл 2007
    Сообщения:
    421
    Симпатии:
    68
    Базы естественно разные. Просмотрел щас базу - в wp_post все посты на месте.
     
  5. yroc

    yroc

    Регистр.:
    13 мар 2007
    Сообщения:
    174
    Симпатии:
    45
    Попробуй восстановить все таблицы.
    С htaccess ничего не делал? Постоянные ссылки не менял?
     
  6. BFox

    BFox

    Регистр.:
    11 янв 2008
    Сообщения:
    368
    Симпатии:
    65
    Да, может что в htaccess.. поставь в начальное состояние ну чтобы ссылки были ?p=id (или как то так) при таких настройках посмотрите будут ли находиться те посты
     
  7. monia

    monia

    Регистр.:
    27 июл 2007
    Сообщения:
    421
    Симпатии:
    68
    Да, так все в порядке, но вот только я хочу, чтобы название поста присутствовало в URL...
    А вот восстановление таблиц не помогло.
    .htaccess правил только в соседнем блоге, на этом ничего не делал, сейчас поставил на него права 777, сохранил настройки постоянных ссылок, но это не помогает.

    В БД в таблице wp_posts параметр guide показывает все ссылки как хttp://.../?p=8
     
  8. BFox

    BFox

    Регистр.:
    11 янв 2008
    Сообщения:
    368
    Симпатии:
    65
    На каждой записи?? Хм.. не должно такого быть.. Видно что-то с вордперсом.. обновите вордпрес перезапишите просто файлы поверх, а те записи проверьте, новые записи нормально пишутся или нет.. правильный путь им пропиписывается в guide или нет
     
  9. monia

    monia

    Регистр.:
    27 июл 2007
    Сообщения:
    421
    Симпатии:
    68
    Про хttp://.../?p=8 это я пример привел, цифры в параметре p= естественно разные для всех постов
     
  10. BFox

    BFox

    Регистр.:
    11 янв 2008
    Сообщения:
    368
    Симпатии:
    65
    Тогда совсем непонятно) Вроде все верно.. тема не может быть кривой? Все равно обнови вордпрес может что в нем криво залилось
     
Статус темы:
Закрыта.