[nginx+windows]

Тема в разделе "Администрирование серверов", создана пользователем Demon425, 2 мар 2009.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. Demon425

    Demon425

    Регистр.:
    9 июл 2008
    Сообщения:
    461
    Симпатии:
    116
    Поставил nginx 0.6.35 (стабильный) отсюда
    http://www.kevinworthington.com/
    в его директорию прикрутил DENWER 3.

    nginx сконфигурировал так:

    Код:
    #user  nobody;
    worker_processes  1;
    
    #error_log  logs/error.log;
    #error_log  logs/error.log  notice;
    #error_log  logs/error.log  info;
    
    #pid        logs/nginx.pid;
    
    
    events {
    	worker_connections  64;
    }
    
    
    http {
        include       mime.types;
        default_type  application/octet-stream;
    	
    	client_header_timeout  1m;
        client_body_timeout    1m;
        send_timeout           1m;
    
        #log_format  main  '$remote_addr - $remote_user [$time_local] $request '
        #                  '"$status" $body_bytes_sent "$http_referer" '
        #                  '"$http_user_agent" "$http_x_forwarded_for"';
    
        #access_log  logs/access.log  main;
    
        sendfile        on;
        #tcp_nopush     on;
    
        #keepalive_timeout  0;
        keepalive_timeout  65;
    
        #gzip  on;
    	gzip on;
    	gzip_min_length 1024;
    	gzip_buffers	4 8k;
    	gzip_types text/html text/xml text/css application/x-javascript text/javascript; 
    
    	server {
    	
    		listen       192.168.94.77:77; # на какой IP и порт вещать
            server_name  demoncomp 192.168.77.77; # внешний адрес, куда вещать
            access_log  /nginx/server/home/custom/acess.log; # файл логов
    	
    		charset cp1251; # кодировка по умолчанию
     
            location /
            {
    				#index  index.php index.html index.htm;
    				
    				log_not_found off;
    				
    				#error_page	404					/html/404.html
    				#error_page	403					/403.html
    				#error_page	503					/50x.html;
    				
                    client_max_body_size  20M;
    				client_body_buffer_size    128k;
     
                    proxy_pass http://127.0.0.1:8080/; # куда передавать запросы, то есть апач
                    proxy_redirect off;
     
                    proxy_set_header   Host             $host;
                    proxy_set_header   X-Real-IP        $remote_addr;
                    proxy_set_header   X-Forwarded-For  $proxy_add_x_forwarded_for;
     
                    proxy_connect_timeout 90;
                    proxy_send_timeout    90;
                    proxy_read_timeout    90;
     
                    proxy_buffer_size          4k;
                    proxy_buffers              4 32k;
                    proxy_busy_buffers_size    64k;
                    proxy_temp_file_write_size 64k;
                    proxy_temp_path            /nginx/var/tmp/nginx;
     
            }
            location  ~* \.(gif|jpg|jpeg|png|ico|js|css|txt|zip|rar|html|htm)$ { #типы статических файлов
    		root  /nginx/server/home/custom/www; # рут сайта
    		access_log   off;
    		expires      30d;
            }
    		
    		# deny access to .htaccess files, if Apache's document root
            # concurs with nginx's one
            #
            #location ~ /\.ht {
    		#					deny  all;
    		#}
     
        }
    }
    на апач поставил apache\modules\mod_rpaf.so

    в httpd.conf прописал LoadModule rpaf_module modules/mod_rpaf.so
    на этом моменте всё работает, но когда пытаюсь добавить:
    RPAFenable On

    # Enable reverse proxy add forward RPAFproxy_ips YOUR_PROXY_SERVER_IP_LIST_OR_ONE_IP
    # which ips are forwarding requests to us

    RPAFsethostname Off

    # let rpaf update vhost settings
    # allows to have the same hostnames as in the "real"
    # configuration for the forwarding Apache

    RPAFproxy_ips 192.168.77.77
    RPAFheader X-Real-IP

    Apache отказывается стартовать ...
    выдаёт это (аттач добавлен)

    Что не так ? и как исправить :((

    03.03.2009
    Проблема решена, тему можно закрывать, правильная настройка RPAF:

    Код:
    RPAFenable On
    RPAFsethostname On
    RPAFproxy_ips 192.168.77.77 127.0.0.1
     

    Вложения:

    • 1.PNG
      1.PNG
      Размер файла:
      3,9 КБ
      Просмотров:
      42
  2. Velindar

    Velindar Прохожие

    А неподелитесь ссылкой на мануальчег? Либо от себя по пунктам)
     
  3. Demon425

    Demon425

    Регистр.:
    9 июл 2008
    Сообщения:
    461
    Симпатии:
    116
    1) ставим nginx ^ссылка выше^
    2) конфигурируем ^пример конфига вверху^
    3) ставим денвер (например) в папку с nginx'ом
    4) перекидываем апач на 127.0.0.1:8080
    5) скачиваем и ставим на Апач мод RPAF (в конфиге LoadModule rpaf_module modules/mod_rpaf.so)
    6) конфигурим RPAF ^конфиг вверху^
    7) перезапускаем и радуемся.

    P.S. Мануалов нету, темболее на русском
     
  4. r00t

    r00t

    Регистр.:
    30 июл 2006
    Сообщения:
    192
    Симпатии:
    65
    Сказав перекидываем апач, Demon425 имел ввиду в httpd.conf

    Listen 127.0.0.1:8080
     
  5. VyacheslavS

    VyacheslavS Писатель

    Регистр.:
    4 май 2009
    Сообщения:
    2
    Симпатии:
    0
    А на 80 порту что будет?

    В конфиге есть:
    Может правильно так:

     
Статус темы:
Закрыта.