[help] Глюк какой-то странный

Тема в разделе "vBulletin", создана пользователем $HARK, 25 фев 2009.

Статус темы:
Закрыта.
  1. $HARK

    $HARK Создатель

    Регистр.:
    5 фев 2009
    Сообщения:
    40
    Симпатии:
    2
    Народ, кто адекватен и кто в теме булки шарит, нужна помощь.
    Хочу разобраться, что случилось и как это лечить.
    Значит, развлекаюсь сейчас с 3.8.1... пытаюсь разобраться че-кого.
    Смысл вот в чем: поставил я шаб какой-то левый на него и долго пытался вкурить, где скины назначаются по умолчанию - не нашел. Ну да и черт с ним, подумал я. Скин удалил, остался только дефолтный. Теперь появилась такая замечательная особенность, набираю в адресной строке браузера ссылку на форум вида: хттп:forum.mydomen.ru - и все. То есть на смерть. HTTP 404 – файл не найден. А если набираю хттп:forum.mydomen.ru/index.php - работает. Что бы это значило? И, главное, какими лекарствами лечится?
    зы: "лучшее лекарство - топор для кривых рук", - такие отвеы несчитово. Потому что хочу понять, что мне с этим делать, а не выслушивать критику от детишек.
     
  2. Grabus

    Grabus Постоялец

    Регистр.:
    7 дек 2007
    Сообщения:
    91
    Симпатии:
    31
    по идее тебе нужно указать серверу стартовую страницу, т.е. чтоб он при обращении к корню отдавал index.php.
    обычно на сервера это идет по дефолту.

    создай (или редактируй) файл .htaccess в корне форума и пропиши туда:
    Добавлено через 2 минуты
    хотя может ты случайно удалил или испортил стандартный файл .htaccess, может просто попробуй его восстановить, если такой был.
     
  3. $HARK

    $HARK Создатель

    Регистр.:
    5 фев 2009
    Сообщения:
    40
    Симпатии:
    2
    К сожалению это не так. .htaccess в порядке. и все там прописано как надо. я его на всякий случай поменял на родной, конечно, но результата - ноль. испортить я его тоже не мог, кстати.. вообще не редактировал. т.е. все, что я вообще сделал, это просто поставил еще один шаблон и в результате теперь даже дефолтный загружается только или по адресу с определением index.php в конце или если вот так:
    хттп:форум.мойдомен.ру/index.php?styleid=1
    мне кажется, что это как-то связано с настройкой стилей, но вот что именно - вопрос.


    UPD: Проблема решена, может кому -то понадобится ее решение, если такая же ситуация возникнет.
    Штука было в том, что форум установлен на поддомен, а на основном домене стоит DLE. Там в корневой папке с форумом в .htaccess нужно было прописать RewriteEngine Off
    Такие дела. Спать нужно больше, тогда косяков будет меньше :)
     
Статус темы:
Закрыта.