[Ссылка] Решение проблем с автообновлением WP 2.7.X

Тема в разделе "Wordpress", создана пользователем ReBeL, 21 фев 2009.

Статус темы:
Закрыта.
Модераторы: DzSoft, Sorcus
  1. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.561
    Симпатии:
    849
    Многие столкнулись с тем, что перестало работать обновление плагинов и базы вордпресса. Для того, чтобы все заработало необходимо добавить в wp-config.php следующую строку :

    Код:
    putenv('TMPDIR=' . ini_get('upload_tmp_dir'));
    Надеюсь многим это поможет =)
     
  2. anga

    anga Писатель

    Регистр.:
    18 янв 2009
    Сообщения:
    5
    Симпатии:
    0
    Вроде на сборках от кактуса все обновляется
     
  3. cardstap

    cardstap Создатель

    Регистр.:
    20 фев 2009
    Сообщения:
    18
    Симпатии:
    2
    На его сборках была проблема с обновлением плагинов, лечилось только ручным обновлением. А вообще кто подскажет смысл автоапдейта там ведь он многие файлы меняет... Чтоже делать с вариантом когда файл исправлялся/дополнялся самостоятельно? Есть ли возможность частичного обновления файла?
     
  4. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.561
    Симпатии:
    849
    Нет - в таком случае только вручную.
    Качается новая версия, вносятся изменения и заливается на сервер
     
  5. dat

    dat

    Регистр.:
    31 окт 2007
    Сообщения:
    436
    Симпатии:
    141
    Не обязательно - зависит от плагина. Локализован ли, имеет ли собственную панель настроек и пр. В любом случае в каждом конкретном случае надо смотреть - авто или ручками.
    А так автообновление в 2.7.1. (сам сейчас юзаю) - очень даже удобно и быстро.
     
  6. S-I

    S-I Постоялец

    Регистр.:
    11 янв 2008
    Сообщения:
    98
    Симпатии:
    10
    Видимо, здесь не все так просто и однозначно. Лично мне это не помогло... однозначно, от хостинга зависит.
     
  7. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.561
    Симпатии:
    849
    Честно говоря это неизвестно от чего зависит....
    Я закономерности не нашел если честно.....
    На 1 сервере с одинаковыми настройками и набором плагинов.....часть блогов работает нормально, а на другой части проблемы с автообновлением......
    Нонсенс, но факт. Вплоть до того, что один и тот же плагин не обновляется в одном месте и без проблем обновляется в другом... бредятина короче. Ждем 2.8....
     
  8. alexzh

    alexzh

    Регистр.:
    13 сен 2006
    Сообщения:
    222
    Симпатии:
    88
    ИМХО лучше добавить в wp-config.php следующую строку :
    define('WP_TEMP_DIR', ABSPATH . 'wp-content/upgrade');
    естественно папка upgrade должна иметь права на запись!
    Если нет сэйфмода то должно хватить 0755, у меня ВП стоит и на
    серверах, где Safe Mode Enabled, там 0777 по другому не работает!

    так что я еще в эту папку .htaccess где разрешаю доступ только себе(ip подсеток из которых выхожу в сеть) и локалхосту так:
    allow from 127.0.0.1
    allow from xxx.xxx.xxx.xxx/24
    deny from all

    и / или .htaccess который можно также и в uploads положить

    RemoveType .phtml .php .php3 .pl .perl .cgi .sh .shtml .shtm .stml .stm
    RemoveHandler .phtml .php .php3 .pl .perl .cgi .sh .shtml .shtm .stml .stm

    <FilesMatch "\.(ph.*|pl|perl|cgi|sh.*|stm.*)$">
    Order Allow,Deny
    Deny from All
    Satisfy All
    </FilesMatch>

    <IfModule mod_rewrite.c>
    RewriteEngine Off
    </IfModule>

    на разных хостах по разному т.к. на новых использую последние наработки, а на старых работает и пусть работает ;-)

    П.С. Тот, кто воображает, что может обийтись без других людей, очень ошибается; но тот, кто воображет, что без него не могут обойтись люди, ошибается еще больше. /Ф.Ларошфурко/
    также можете в гугле поискать по запросу WP_TEMP_DIR и почитать что буржуи пишут
     
  9. ReBeL

    ReBeL Злобный старикашка

    Регистр.:
    3 май 2006
    Сообщения:
    1.561
    Симпатии:
    849
    Вообщем путем проб и ошибок заставил на всех своих блогах работать обновление плагинов =)

    Решение банальное до невозможности оказалось =)

    В поле Hostname указываем localhost
    И все работает =)
     
  10. NUrzhyk

    NUrzhyk Постоялец

    Регистр.:
    8 июн 2008
    Сообщения:
    94
    Симпатии:
    31
    Где ты это указал? В файле wp-config.php или в админке ?
     
Статус темы:
Закрыта.